#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^CDPHP_SPRPT_GapList_[0-9]{6}(2[0-1]|1[01][0-9]|1[6-9])_[0-9]{9}.txt"
Local $sString = "NY_Community_CLM_DIAG_08282019.txt" & @CRLF & _
"NY_Community_CLM_DIAG_07152019.txt" & @CRLF & _
"CDPHP_SPRPT_GapList_20191028_619675879.txt" & @CRLF & _
"CDPHP_SPRPT_GapList_20191021_617641986.txt" & @CRLF & _
"CDPHP_SPRPT_GapList_20191017_616743586.txt" & @CRLF & _
"CDPHP_SPRPT_GapList_20191040_619675879.txt" & @CRLF & _
"CDPHP_SPRPT_GapList_20191018_616743586.txt" & @CRLF & _
"CDPHP_SPRPT_GapList_20191019_616743586.txt" & @CRLF & _
"CDPHP_SPRPT_GapList_20191020_616743586.txt" & @CRLF & _
"CDPHP_SPRPT_GapList_20191016_616743586.txt" & @CRLF & _
"CDPHP_SPRPT_GapList_20191015_616743586.txt" & @CRLF & _
"CDPHP_SPRPT_GapList_20191009_616743586.txt" & @CRLF & _
"CDPHP_SPRPT_GapList_20200816_616743586.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")