#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[1-9](?:,?\d){7}\b"
Local $sString = "From RE: Markitwire: 120432889: Mx: 24,693,059 i need to get 24693059" & @CRLF & _
"" & @CRLF & _
"From Automatic reply: Auftrag zur Übertragung IRD Ref-Nr. MMX_23497152 need to get 23497152" & @CRLF & _
"" & @CRLF & _
"From FW: CGMSE 2019-2X A1AN XS2022418672 Contract 24663537 need to get 24663537" & @CRLF & _
"From RE: BBVA-MAD MMX_24644644 + MMX_24644645 need to get 24644644, 24644645" & @CRLF & _
"" & @CRLF & _
"TGF00023242526"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")