const regex = / +.+ +\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' +.+ +\\)', 'gm')
const str = `This pack includes:
PEARSON.ADVANCED.REACT.JS.LIVELESSONS-iLLiTERATE ( 5.4 GiB )
PEARSON.BUILDING.MICROSERVICES.WITH.SPRING.BOOT.SECOND.EDITION-iLLiTERATE ( 20.7 GiB )
PEARSON.BUILDING.SPARK.APPLICATIONS-iLLiTERATE ( 9.199999999999999 GiB )`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}