#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((http:|https:)\/\/i\.imgur\.com\/)"
Local $sString = "https://i.imgur.com/w33xd" & @CRLF & _
"https://i.imgur.com/3234z.jpg" & @CRLF & _
"http://i.imgur.com/33" & @CRLF & _
"http://i.imgur.com/23"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")