package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((http:|https:)\/\/i\.imgur\.com\/)`)
var str = `https://i.imgur.com/w33xd
https://i.imgur.com/3234z.jpg
http://i.imgur.com/33
http://i.imgur.com/23`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}