import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((http:|https:)\\/\\/i\\.imgur\\.com\\/)";
final String string = "https://i.imgur.com/w33xd\n"
+ "https://i.imgur.com/3234z.jpg\n"
+ "http://i.imgur.com/33\n"
+ "http://i.imgur.com/23";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}