package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+(\.\d+)?)`)
var str = `'Discount 7.5%' should get 7.5
'Discount 15%' should get 15
'Discount 10%' should get 10
'Discount 5%' should get 5`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}