#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ix)(<\?=)" & @CRLF & _
"(" & @CRLF & _
" (" & @CRLF & _
" (?!" & @CRLF & _
" (htmlspecialchars|htmlentities|json_encode)" & @CRLF & _
" )" & @CRLF & _
" ." & @CRLF & _
" )*" & @CRLF & _
" [\$]{1,}" & @CRLF & _
" (.*)" & @CRLF & _
")" & @CRLF & _
"(\?>)"
Local $sString = "<?= $lorem ?>" & @CRLF & _
"<?= _($lorem) ?>" & @CRLF & _
"" & @CRLF & _
"<?= 'ipsumz' ?>" & @CRLF & _
"<?= _('ipsum') ?>" & @CRLF & _
"" & @CRLF & _
"//Conditions ternaires" & @CRLF & _
"<?= ($a == $b) ? 'lorem' : 'ipsum' ?>" & @CRLF & _
"" & @CRLF & _
"//Chaînes contenant un htmlspecialchars()" & @CRLF & _
"<?= 'lorem ' . htmlspecialchars('lorem ipsum') ?>" & @CRLF & _
"" & @CRLF & _
"//Chaînes contenant un htmlentities()" & @CRLF & _
"<?= htmlentities('lorem ipsum') ?>"
Local $sSubst = "purify($2)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)