using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<\?=)
(
(
(?!
(htmlspecialchars|htmlentities|json_encode)
)
.
)*
[\$]{1,}
(.*)
)
(\?>)";
string substitution = @"purify($2)";
string input = @"<?= $lorem ?>
<?= _($lorem) ?>
<?= 'ipsumz' ?>
<?= _('ipsum') ?>
//Conditions ternaires
<?= ($a == $b) ? 'lorem' : 'ipsum' ?>
//Chaînes contenant un htmlspecialchars()
<?= 'lorem ' . htmlspecialchars('lorem ipsum') ?>
//Chaînes contenant un htmlentities()
<?= htmlentities('lorem ipsum') ?>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}