package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(<\?=)
(
(
(?!
(htmlspecialchars|htmlentities|json_encode)
)
.
)*
[\$]{1,}
(.*)
)
(\?>)`)
var str = `<?= $lorem ?>
<?= _($lorem) ?>
<?= 'ipsumz' ?>
<?= _('ipsum') ?>
//Conditions ternaires
<?= ($a == $b) ? 'lorem' : 'ipsum' ?>
//Chaînes contenant un htmlspecialchars()
<?= 'lorem ' . htmlspecialchars('lorem ipsum') ?>
//Chaînes contenant un htmlentities()
<?= htmlentities('lorem ipsum') ?>`
var substitution = "purify($2)"
fmt.Println(re.ReplaceAllString(str, substitution))
}