$re = '/(<\?=)
(
(
(?!
(htmlspecialchars|htmlentities|json_encode)
)
.
)*
[\$]{1,}
(.*)
)
(\?>)/ix';
$str = '<?= $lorem ?>
<?= _($lorem) ?>
<?= \'ipsumz\' ?>
<?= _(\'ipsum\') ?>
//Conditions ternaires
<?= ($a == $b) ? \'lorem\' : \'ipsum\' ?>
//Chaînes contenant un htmlspecialchars()
<?= \'lorem \' . htmlspecialchars(\'lorem ipsum\') ?>
//Chaînes contenant un htmlentities()
<?= htmlentities(\'lorem ipsum\') ?>';
$subst = "purify($2)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;