use strict;
my $str = 'aaaaa8A?';
my $regex = qr/((?:(?=^\S{8,}$)(?:(?=\S*\d)(?=\S*[A-Z])(?=\S*[a-z])|(?=\S*\d)(?=\S*[^A-Za-z0-9])(?=\S*[a-z])|(?=\S*[^A-Za-z0-9])(?=\S*[A-Z])(?=\S*[a-z])|(?=\S*\d)(?=\S*[A-Z])(?=\S*[^A-Za-z0-9]))^\S*){8,})/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}