const regex = /^[a-zA-ZΑ-Ω\d]*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-ZΑ-Ω\\d]*$', '')
const str = `ΑΣΔΑΔasdakqweASKDJHkASNDA123123123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}