import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@param\\s+\\{\\(?([^\\}]+)\\)?\\}\\s+(\\[.+\\]|[\\w]+(?:\\[.+\\])?)\\s+([\\s\\S]*?)(?=\\@|\\*\\/)";
final String string = "/**\n"
+ " * Removes elements from \\`array\\` corresponding to \\`indexes\\` and returns an\n"
+ " * array of removed elements.\n"
+ " *\n"
+ " * **Note:** Unlike \\`_.at\\`, this method mutates \\`array\\`.\n"
+ " *\n"
+ " * @static\n"
+ " * @memberOf _\n"
+ " * @category Array\n"
+ " * @param {Array} array The array to modify.\n"
+ " * @param {...(number|number[])} [indexes] The indexes of elements to remove,\n"
+ " * specified individually or in arrays.\n"
+ " * @returns {Array} Returns the new array of removed elements.\n"
+ " * @example\n"
+ " *\n"
+ " * var array = [5, 10, 15, 20];\n"
+ " * var evens = _.pullAt(array, 1, 3);\n"
+ " *\n"
+ " * console.log(array);\n"
+ " * // => [5, 15]\n"
+ " *\n"
+ " * console.log(evens);\n"
+ " * // => [10, 20]\n"
+ " */\n"
+ "var pullAt = rest(function(array, indexes) {\n"
+ " indexes = arrayMap(baseFlatten(indexes), String);\n\n"
+ " var result = baseAt(array, indexes);\n"
+ " basePullAt(array, indexes.sort(compareAscending));\n"
+ " return result;\n"
+ "});";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}