// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"[\s\n]*data-dcm-click-tracker[=|\s]([\\'"a-zA-Z0-9-%]*)"#).unwrap();
let string = "data-dcm-click-tracker=\"sdfsdf\"
sdfs
data-dcm-click-tracker='sdfsdf'
sdfs
data-dcm-click-tracker=\\'sdfsdf\\'
data-dcm-click-tracker=\\\"sdfsdf\\\"
data-dcm-click-tracker=sdfsdfcc
data-dcm-click-tracker=df
data-dcm-click-tracker='%ZZDCLICK%' xcxcx
sdfsdfdf data-dcm-click-tracker ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}