using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)(\s)(\w+)(\s)(\w+)(\s)(\w+)(\s)(\d){4}";
string input = @"CORREDORES PERSONA NATURAL MOROSOS AL 20 DE JUNIO DE 2019";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}