import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)(\\s)(\\w+)(\\s)(\\w+)(\\s)(\\w+)(\\s)(\\d){4}";
final String string = "CORREDORES PERSONA NATURAL MOROSOS AL 20 DE JUNIO DE 2019";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}