$re = '/(\d+)(\s)(\w+)(\s)(\w+)(\s)(\w+)(\s)(\d){4}/m';
$str = 'CORREDORES PERSONA NATURAL MOROSOS AL 20 DE JUNIO DE 2019';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);