re = /^(?=.{10}(.*))[A-Za-z]+:[0-9]+(?=\h*\1$)/m
str = 'A:12345678
A:123456789
FOO:567890s123
LOREM:42 ipsum'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end