#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{10}(.*))[A-Za-z]+:[0-9]+\h*(?=\1$)"
Local $sString = "A:12345678" & @CRLF & _
"A:123456789" & @CRLF & _
"FOO:567890s123" & @CRLF & _
"LOREM:42 ipsum"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")