use strict;
my $str = 'A:12345678
A:123456789
FOO:567890s123
LOREM:42 ipsum';
my $regex = qr/^(?=.{10}(.*))[A-Za-z]+:[0-9]+\h*(?=\1$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}