re = /^(.+?)(?:(?:@example1\.com)?|(?=@))$/m
str = 'test@example1.com
test@example2.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end