import Foundation
let pattern = #"(201[6-9])-(0?[1-9]|1[012])-(0?[1-9]|[12][0-9]|3[01])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
$(date +%Y-%m-%d)
2016-07-25
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}