import re
regex = re.compile(r"<span[^>)()]*\((\d+)\)[^>]*>")
test_str = ("<span class=\"b-label b-link-number\" data-num=\"(322206)\">Music & Video</span>\n"
"<span class=\"b-label b-link-number\" data-num=\"(954218)\">Toys, Hobbies & Games</span>\n"
"<span class=\"b-label b-link-number\" data-num=\"(502981)\">Kids, Baby & Maternity</span>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")