re = /<span[^>)()]*\((\d+)\)[^>]*>/
str = '<span class="b-label b-link-number" data-num="(322206)">Music & Video</span>
<span class="b-label b-link-number" data-num="(954218)">Toys, Hobbies & Games</span>
<span class="b-label b-link-number" data-num="(502981)">Kids, Baby & Maternity</span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end