using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/[^.\n]*?(?:=.*)?$";
string substitution = @"";
string input = @"/test
/test/123
/test/123/1
/test/123/1?q=test
/test/123/1?q=test.period
/test.js
/img/123.jpg
/script/app.js?version=1.0
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}