$re = '/\[\[NOTE]]((?:(?!\[\[NOTE\]\]).)*)\[\[NOTE]]/m';
$str = '[[NOTE]]This is my note.[[NOTE]]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;