import Foundation
let pattern = #"\[\[NOTE]]((?:(?!\[\[NOTE\]\]).)*)\[\[NOTE]]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[[NOTE]]This is my note.[[NOTE]]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)