re = /^(?:(?:0|\+33)(?:6|7))\d{8}$/m
str = '0611223344
0744332211
+33611223344
+33744332211
06112233440744332211
+33611223344+33611223344
0611223344 0744332211
0744332211+33611223344
0744332211 +33611223344'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end