# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(red|blue|green) (colou?r|chroma)/\1 hue/gm;t' <<< "red color"