re = /(red|blue|green) (colou?r|chroma)/m
str = 'red color'
subst = '\\1 hue'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result