// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(red|blue|green) (colou?r|chroma)").unwrap();
let string = "red color";
let substitution = "\\1 hue";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}