import Foundation
let pattern = #"(red|blue|green) (colou?r|chroma)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"red color"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 hue"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)