#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?:\d+\s*x\s*)?(?:\d+[.,])?\d+\s*L?\s*$"
Local $sString = "25 Test Drink 60% 12x1,0L" & @CRLF & _
"Test Drink 60% 2x0,5" & @CRLF & _
"Test Drink 3 x 0,75 L " & @CRLF & _
"Test Drink 4x0,75 L" & @CRLF & _
"Test Drink 5 x 0,75L" & @CRLF & _
"Test Drink 66 x 0,75 " & @CRLF & _
"Test Drink 0,75 " & @CRLF & _
"Test Drink 0.75 " & @CRLF & _
"7UP 12 x 1 L"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")