re = /(?:\d+\s*x\s*)?(?:\d+[.,])?\d+\s*L?\s*$/mi
str = '25 Test Drink 60% 12x1,0L
Test Drink 60% 2x0,5
Test Drink 3 x 0,75 L
Test Drink 4x0,75 L
Test Drink 5 x 0,75L
Test Drink 66 x 0,75
Test Drink 0,75
Test Drink 0.75
7UP 12 x 1 L'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end