const regex = /^\d{4}-(0\d|1[0-2])-([0-2]\d|3[0-2])(T(([01]\d|2[0-4]):([0-5]\d)(:[0-5]\d([\.,]\d+)?)?|([01]\d|2[0-4])(:[0-5]\d([\.,]\d+)?)?|([01]\d|2[0-4])([\.,]\d+)?))?([+-]\d\d(:[0-5]\d)?|Z)?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{4}-(0\\d|1[0-2])-([0-2]\\d|3[0-2])(T(([01]\\d|2[0-4]):([0-5]\\d)(:[0-5]\\d([\\.,]\\d+)?)?|([01]\\d|2[0-4])(:[0-5]\\d([\\.,]\\d+)?)?|([01]\\d|2[0-4])([\\.,]\\d+)?))?([+-]\\d\\d(:[0-5]\\d)?|Z)?$', '')
const str = `2016-03-12T14:13:12.1209182451+03:00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}