re = /[a-zA-Z]{3,4}[0-9]{2}[0-1]{1}[0-9]{1}[0-3]{1}[0-9]{1}[a-zA-Z0-9]{3}/
str = 'UGU250907MH5
UGU001939333
HHHH250907MH5
BBBBB20907MH5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end