#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\n\n(.*?)Show Abstract - Show Citation"
Local $sString = "Plenary Papers (1)" & @CRLF & _
"Peer-reviewed Papers (113)" & @CRLF & _
"PLENARY MANUSCRIPTS (1)" & @CRLF & _
"First Author Index" & @CRLF & _
"" & @CRLF & _
"Harrer" & @CRLF & _
"Plenary Papers" & @CRLF & _
"" & @CRLF & _
"Some title number one" & @CRLF & _
"John W. Doe" & @CRLF & _
"2018 Physics SOmething Proceedings" & @CRLF & _
"Full Text: Download PDF - PER-Central Record" & @CRLF & _
"Show Abstract - Show Citation" & @CRLF & _
"PEER REVIEWED MANUSCRIPTS (113)" & @CRLF & _
"First Author Index" & @CRLF & _
"" & @CRLF & _
"Doe · Doe2 · Doe3 · Jonathan" & @CRLF & _
"Peer-reviewed Papers" & @CRLF & _
"" & @CRLF & _
"Some title number two" & @CRLF & _
"Alex White, Paul Klee, and Jacson Pollock" & @CRLF & _
"2018 Physics Research Conference Proceedings, doi:10.1234/perc.2018.pr.White" & @CRLF & _
"Full Text: Download PDF - PER-Central Record" & @CRLF & _
"Show Abstract - Show Citation" & @CRLF & _
"" & @CRLF & _
"Some title number three" & @CRLF & _
"Suzanne Heck, Alex Someone, John I. Smith, and Andrew Bourgogne" & @CRLF & _
"2018 Physics Education Research Conference Proceedings, doi:10.2345/perc.2018.pr.Heck" & @CRLF & _
"Full Text: Download PDF - PER-Central Record" & @CRLF & _
"Show Abstract - Show Citation" & @CRLF & _
"" & @CRLF & _
".."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")