use strict;
my $str = 'некий текст[36465464]';
my $regex = qr/\[\d+\]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";