re = /(?<!\w)-(\w+)-(?!\w)|(?<!\w)-(\w+)|(\w+)-(?!\w)/
str = 'xxx yyy -removethis andthis- foo-bar zzz -andalsothis-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end