using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<={).*(?=})";
string input = @"C:\ADBackup\GPOs{7AF2FC2F-7A88-47BB-9F61-BEE0C929DF6E}\User\Preferences\Drives\Drives.xml";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}