package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https:\/\/www\.youtube\.com\/watch\?v=([a-zA-Z0-9]+)`)
var str = `https://www.youtube.com/watch?v=TF3KeTOL9Ac`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}