#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(([0-9a-z-A-Z]+){1}+((\s+[a-zA-Z.,]+|\s+[a-zA-Z,.]+\s){2,10})?(\#[0-9a-z-\-]+|\#\s+[0-9\-]+|[0-9\-]+))"
Local $sString = "3724 South Laurelcrest Street Salt Lake City," & @CRLF & _
"3724 S Laurelcrest St " & @CRLF & _
"Salt Lake City, UT 84109-3757" & @CRLF & _
"thisis a " & @CRLF & _
"7850 S Dean Martin Dr Suite 505" & @CRLF & _
"" & @CRLF & _
"4590-3- test concealesd siote 404" & @CRLF & _
"" & @CRLF & _
"747 Sheridan Blvd, #3a, Lakewood, CO 80214"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")