$re = '/(([0-9a-z-A-Z]+){1}+((\s+[a-zA-Z.,]+|\s+[a-zA-Z,.]+\s){2,10})?(\#[0-9a-z-\-]+|\#\s+[0-9\-]+|[0-9\-]+))/';
$str = '3724 South Laurelcrest Street Salt Lake City,
3724 S Laurelcrest St
Salt Lake City, UT 84109-3757
thisis a
7850 S Dean Martin Dr Suite 505
4590-3- test concealesd siote 404
747 Sheridan Blvd, #3a, Lakewood, CO 80214';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);