re = /^(.*?-.*?)-.*$/m
str = '60166213
60173866-4533
60167323-9439-1259801
NL170-2683-1262201
60174710-1-A12-4'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result