import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<input\\s+name=\"data\\[Product\\]\\[name\\]\"\\s+value=\"([^\"]+)\"";
final String string = "<input name=\"data[Product][name]\" value=\"Бумага SvetoCopy Ð4 80г/м 500л.\" type=\"hidden\">\n"
+ "<input name=\"data[Product][name]\" value=\"Бумага SvetoCopy Ð3 80г/м 500л.\" type=\"hidden\">\n"
+ "<input name=\"data[Product][name]\" value=\"Бумага Снегурочка Ð4 80г/м 500л.\" type=\"hidden\">\n"
+ "<input name=\"data[Product][name]\" value=\"Ручка гел. Ñин 05 ЕК8791\" type=\"hidden\">";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}