$re = '/^(\+\d-)?\(?(\d{1,3})\)?[\s-\.]?(\d{1,3})[\s-\.]?(\d{1,4})[\s-\.]?/m';
$str = '555.123.4565
+1-(800)-545-2468
555-123-3456
555 222 3342
(234) 234 2442
(243)-234-2342
1234567890
(123)2567890';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);