import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!.*Rejected.*)RC:\\*.*?(?P<Capture>(Bob|David|Ted|Alice)).*";
final String string = "RC:* Hi Bob Smith<\\person>\n"
+ "RC:* Hi David Jones *Notes Bla bla<\\person>\n"
+ "RC:* Hi Ted Warren *Rejected <\\person>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}