using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(#[0-9a-f]{6})(.+?)(?=#[0-9a-f]{6}|$)";
string input = @"#ff00fffirstword#445533secondword##008877thi#rdword#";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}