#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[AM]\d{4}.*|(.+)"
Local $sString = "A1234" & @CRLF & _
"M3232" & @CRLF & _
"M3425435324" & @CRLF & _
"MM3453" & @CRLF & _
"JHLKJGA1234" & @CRLF & _
"string with nothing"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")